1999 s10 2.2 check engine light issues - S-10 Forum
 
LinkBack Thread Tools
post #1 of 8 Old 10-11-2004, 04:07 PM Thread Starter
Registered User
 
Join Date: Aug 2002
Location: North Adams MA
Age: 38
Posts: 38

User is: XxDaZxX is offline
Send a message via AIM to XxDaZxX
Angry 1999 s10 2.2 check engine light issues

Ok heres my prob i drive a 1999 s10 2.2 my check engine light is on, i had to get my truck inspected last month and it showed codes P0134 & P0141. I changed both O2 sensors, the one befor the cat and the one after and also changed the sensor that was in my intake. i reset my battery and i can drive it for like 2 to 3 days then the fu#*ing light comes back on. but here is the weird part the light only comes on early in the morning when it is cold and damp out. i leave for work like at 6am. i dont have an auto zone where i live so no free scans and i refuse to pay 40 to 50 bucks to have it done. has anyone had or seen someone with this prob befor?

thanks everyone for your help, im about to trade this truck in if i cant get it to pass insp ection!

XxDaZxX is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-11-2004, 04:26 PM
Whoosh I'm Invisible!!
 
fatalsw1tch's Avatar
 
Join Date: Apr 2004
Location: Stanwood, WA
Age: 30
Posts: 42

User is: fatalsw1tch is offline
Re: 1999 s10 2.2 check engine light issues

That sounds pretty odd. Mine did that but I found out the wire to my gaudge cluster was not fully seatted. But that wouldn't make much of a diffrence.

It is proably nothing major but you should have it checked out if don't know what it is.

2001 Victory Red Xtreme 2.2L Ext Cab

Just because I'm a poor Best buy working college student don't mean I can't run with the big boys.
fatalsw1tch is offline  
post #3 of 8 Old 10-11-2004, 04:36 PM
Minitrucker
 
CrEaPeR's Avatar
 
Join Date: Dec 2002
Location: Waldorf, MD
Age: 34
Posts: 2,408

User is: CrEaPeR is offline
Send a message via AIM to CrEaPeR Send a message via Yahoo to CrEaPeR
Re: 1999 s10 2.2 check engine light issues

Hey man if you want a snanner check this one out http://cgi.ebay.com/ebaymotors/ws/eB...category=43989
i was worried out it working but it does. i have the same problem as you (no autozone close to me) . but if you are only getting the codes in the morning i wouldnt wory about it.
CrEaPeR is offline  
post #4 of 8 Old 10-11-2004, 05:03 PM Thread Starter
Registered User
 
Join Date: Aug 2002
Location: North Adams MA
Age: 38
Posts: 38

User is: XxDaZxX is offline
Send a message via AIM to XxDaZxX
Re: 1999 s10 2.2 check engine light issues

thanks guys for the help, yes my truck runs fine but it wont pass inspection with the light on, i live in MA and the inspection tests are getting worse every yeari got my battery disconted agine ill see if it comes on in the morning tomarrow. ill just have to reset it befor i go to get it inspected agin.
XxDaZxX is offline  
post #5 of 8 Old 10-11-2004, 05:09 PM
Registered User
 
Join Date: May 2003
Location: Louisville,Ky
Age: 36
Posts: 709

User is: Jay02XBlazer is offline
Send a message via AIM to Jay02XBlazer
Re: 1999 s10 2.2 check engine light issues

heres a list to all the codes advailable of obdII

P0134 O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 1)

P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

sounds like a poss bad cat or hollowed cat

Jay

try when truck is cooled down getting under truck and hitting the cat with your hand and see if it rattles if so it is possibley bad or you may have a exhaust leak


Last edited by jay98s10; 10-11-2004 at 05:13 PM.
Jay02XBlazer is offline  
post #6 of 8 Old 10-11-2004, 05:12 PM Thread Starter
Registered User
 
Join Date: Aug 2002
Location: North Adams MA
Age: 38
Posts: 38

User is: XxDaZxX is offline
Send a message via AIM to XxDaZxX
Re: 1999 s10 2.2 check engine light issues

Quote:
Originally Posted by jay98s10
heres a list to all the codes advailable of obdII

P0134 O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 1)

P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

sounds like a poss bad cat or hollowed cat

Jay
i have a brand new cat a muff. and changed both of the 02's that came up.
XxDaZxX is offline  
post #7 of 8 Old 10-11-2004, 05:15 PM
Registered User
 
Join Date: May 2003
Location: Louisville,Ky
Age: 36
Posts: 709

User is: Jay02XBlazer is offline
Send a message via AIM to Jay02XBlazer
Re: 1999 s10 2.2 check engine light issues

here the link

http://www.obdiicsu.com/Docs/DTC/DTCData.html

new cat just wondering what kinda cat i have heard of some issues with a/m cats

also check the doughnut gasket on the header/downpipe i have burned though3 of them but not a downpipe yet
Jay

the reason for light coming back on after 2 -3 day is that the computer will test the fix for 3 cycles after the 3 cycles it is still not working it will set a MIL (malfuction Indicater Light) i would cech connections and make sure the wires didnt get to close to the exhaust and short out the sensors

Jay


Last edited by jay98s10; 10-11-2004 at 05:21 PM.
Jay02XBlazer is offline  
post #8 of 8 Old 10-11-2004, 05:28 PM Thread Starter
Registered User
 
Join Date: Aug 2002
Location: North Adams MA
Age: 38
Posts: 38

User is: XxDaZxX is offline
Send a message via AIM to XxDaZxX
Re: 1999 s10 2.2 check engine light issues

thanks man ill have to check the gasket i know i had it replaced like 2 years ago, i have no idea what brand of cat i got, i brought it off line and paid like 70 bucks for it, and i have a flowmaster 40 series muff, tbs, and volant intake.
XxDaZxX is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome