1998 2.2 s10 serious loss of power/rough idle *help* - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

1998 2.2 s10 serious loss of power/rough idle *help*

Go Back   S-10 Forum > Engine and Drivetrain Tech > 2.2L - 2nd gen 4-banging
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 12-16-2012, 06:33 PM   #1
Registered User
 
Join Date: Dec 2012
Posts: 2
Location:
User is: OffLine
1998 2.2 s10 serious loss of power/rough idle *help*

sup guys, just created this account because ive hit a wall in figuring out what is wrong with this thing. the issue im having is a serious misfire, but no misfire codes. it started as an intermittent problem and the truck would randomly miss while driving, then it started when it was raining out, then one day it started to do it more than it wasnt. the truck has 205xxx miles, and i figured it needed plugs and wires, and when i replaced the plugs 3 of the 4 looked fine, but cyl. #4's plug looked terrible, the electrode was bent, the ceramic was cracked and the tip was very pitted. ive found out this is cause from detonation/misfires. well after replaced the plugs and wires it ran like a dream for about 2 days, then all at once it just started missing again while driving. i found a coil to have a crack in it, so i figured i should replace both, they did not fix the issue. i then got a junk yard ignition module, which also fixed nothing. also if you remove any of the plug wires, except for cyl. #1, they wont change the symptom. cyl. #2 and cyl.#4 are getting a weaker spark than #1 and #3. possible crank sensor, or should i look at fuel? any help would be awesome thanks
Old 12-16-2012, 11:41 PM   #2
Registered User
 
Age: 50
Join Date: Jan 2012
Posts: 1,033
Location: Way down in Louisiana.
User is: OffLine
Re: 1998 2.2 s10 serious loss of power/rough idle *help*

Hope you figure it out and be sure to post your results. I lot of us have misfires we can't solve.
Old 12-16-2012, 11:57 PM   #3
Registered User
 
Age: 26
Join Date: Jun 2008
Posts: 189
Location:
User is: OffLine
Re: 1998 2.2 s10 serious loss of power/rough idle *help*

Does it run? How are you checking for spark? I would say there is something is arcing or grounding out. I wouldn't go after any sensors yet, crank sensor and cam sensor will usually fail and you will get no spark or fuel to any cylinders, or start dropping a cylinder or multiple cylinders randomly not the same one every time. You could check for power at the injectors and also that the computer is pulling each to ground, however I would suspect the plug wires even though they are new make sure none are melted or cut. If it runs hose it down and see if it gets worse.
Old 12-17-2012, 06:42 AM   #4
It's "Neanderthal"
 
SH-60B's Avatar
 
Join Date: Nov 2007
Posts: 5,072
Location: Meriden/CT/USA
User is: OffLine
Re: 1998 2.2 s10 serious loss of power/rough idle *help*

Have you checked the new #4 spark plug? If it was a bent ground strap on the old plug, something hit it.
Old 12-24-2012, 12:57 PM   #5
Registered User
 
Join Date: Dec 2012
Posts: 2
Location:
User is: OffLine
Re: 1998 2.2 s10 serious loss of power/rough idle *help*

ok. i figured out what the issue was. upon furthur diagnosing the headgasket let go (207xxx miles) so i figured screw it and i reasealed the top end. upon removing the head i found a bolt holding the intake valve open on cyl#4....i just bought the truck and havent done anything to it, so the previous owner must have dropped it in the intake. upon removing the bolt i inspected the valve and valve seat. the valve seemed ok, but the seat had a slight nick in it. the valve didnt seat perfectly, but considering its just my winter beater i figured it would be ok. well i got it all back together and the truck now idles on its own and runs better, but there is still a misfire on cyl. #4. im guessing its from that valve and seat. so it looks like ill be pulling the head again here pretty soon. thanks for your help guys and ill keep you filled in
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:52 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.