1995 S10 SS 2.2L will crank, won't start - S-10 Forum
 
LinkBack Thread Tools
post #1 of 9 Old 07-17-2013, 12:48 PM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
1995 S10 SS 2.2L will crank, won't start

Hey guys
I'm brand new here at the forum and I've been scouring it for answers. I guess I should start out by saying I was given a '95 SS (2.2L) 5 speed around January. I know that it's not a 'true' S10 ss, it's rather weak, i know, but it's my first car. It's been a challenge because it was given to me with no engine in it, trans, fuel lines etc. I have been working on it since then in my high schools auto shop. I finished it up about late June, had to replace the engine (original engine dropped a rod, according to my uncle who gave it to me), clutch, mate the trans and the engine, run some fuel lines, injectors, cooling, and all that good stuff. Anyway, I finished it up around mid June, had to deal with a faulty temp sensor, but fixed it right up and test drove it. It ran pretty strong...for a while that is. After driving it around my high school campus, my dad drove it home while I followed him in our "chase car". We made it 13 miles (5 miles out from home) before it just died. He tried to do a rolling start to get it to turn over but no go. We pulled it over and started checking fuses, plugs, wiring, battery, etc. We eventually called AAA and got it towed back to our house where it's sat ever since. Used a timing light on it, noticed that none of the cylinders are getting a spark, so we went ahead and started checking out the coil packs, icm, crank sensor etc. We noticed that the coil packs were on the lower resistance side of things, so we replaced them. I took my icm to auozone, had it tested about 5 times, it passed every single time. Replaced the crank sensor, still will crank but won't turn over and run. Even checked the alternator just to make sure. I'm getting rather confused and running out of ideas here, any help would be appreciated. I'm just a noob here, don't kill meh!
Thanks in advance guys,
Drew

Drewski is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-17-2013, 01:04 PM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
Re: 1995 S10 SS 2.2L will crank, won't start

Quick update, my left turn signal randomly came on when I just had the ignition on, checking gauges, even with the stalk in neutral. Possible short that could prevent it from turning over? Not sure

1995 S10 SS 2.2L 5 speed, summit white
Drewski is offline  
post #3 of 9 Old 07-18-2013, 01:41 PM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
Re: 1995 S10 SS 2.2L will crank, won't start

Didn't find a short, just a broken hazard light switch. Any help would be appreciated, still don't know whats going on with it.

1995 S10 SS 2.2L 5 speed, summit white
Drewski is offline  
post #4 of 9 Old 07-19-2013, 03:54 AM
Registered User
 
Join Date: Apr 2011
Posts: 109

User is: 032484 is offline
Re: 1995 S10 SS 2.2L will crank, won't start

check if the plugs are getting any spark. Autozone sells an ignition tester that looks like a spark plug for about $8 works great. Also check if you fuel pump turns on when you turn the ignition on.
032484 is offline  
post #5 of 9 Old 07-19-2013, 09:42 AM
B4U Task Force
 
Rhotpursuit's Avatar
 
Join Date: Sep 2003
Location: Spanaway, Wa
Posts: 11,558

User is: Rhotpursuit is offline
Re: 1995 S10 SS 2.2L will crank, won't start

Already stated...no spark. op...check Flak7's threads (advanced search). He has a 2.2 that had a no spark issue but I don't remember what the cause was.

U.S.C.G. "So others may live"

Apple Red 96 SS
Rhotpursuit is offline  
post #6 of 9 Old 07-21-2013, 05:09 PM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
Re: 1995 S10 SS 2.2L will crank, won't start

thanks, will do

1995 S10 SS 2.2L 5 speed, summit white
Drewski is offline  
post #7 of 9 Old 07-30-2013, 11:39 AM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
Re: 1995 S10 SS 2.2L will crank, won't start

I haven't been able to find that thread, can someone direct me to it? Any ideas anyone?

1995 S10 SS 2.2L 5 speed, summit white
Drewski is offline  
post #8 of 9 Old 07-30-2013, 11:50 AM
B4U Task Force
 
Rhotpursuit's Avatar
 
Join Date: Sep 2003
Location: Spanaway, Wa
Posts: 11,558

User is: Rhotpursuit is offline
Re: 1995 S10 SS 2.2L will crank, won't start

pm flak7

U.S.C.G. "So others may live"

Apple Red 96 SS
Rhotpursuit is offline  
post #9 of 9 Old 07-30-2013, 08:15 PM Thread Starter
Registered User
 
Drewski's Avatar
 
Join Date: Jul 2013
Posts: 11

User is: Drewski is offline
Re: 1995 S10 SS 2.2L will crank, won't start

Alright, I also noticed i have a really loose connection on my starter solenoid, seems like a connector is actually breaking off. Could this possibly prevent the truck from turning over?

1995 S10 SS 2.2L 5 speed, summit white
Drewski is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome