truck wont start unless i spray some starting fluid? - S-10 Forum

 
LinkBack Thread Tools
post #1 of 40 Old 12-28-2007, 04:25 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
truck wont start unless i spray some starting fluid?

well my trck will not start up unless i spray some starting fluid in the tbi, but one its on on it runs great with no problem. i just changed my fuel filter, injector and did a tune up on it what can it be.

blazin_low_713 is offline  
Sponsored Links
Advertisement
 
post #2 of 40 Old 12-28-2007, 06:07 PM
The Eye is watching you!!
 
kamesama980's Avatar
 
Join Date: Nov 2007
Location: dekalb, IL, USA
Age: 31
Posts: 963

User is: kamesama980 is offline
Send a message via AIM to kamesama980 Send a message via Yahoo to kamesama980
Re: truck wont start unless i spray some starting fluid?

does it eventually start if you keep cranking it? if it starts eventually on it's own, then you have a ever so slight leak losing pressure as it sits overnight. not enough to lose gas just enough to lose pressure when it sits for long periods. My car does that...I figure it give me time to pressurize the oil system.

If it won't start at all whatsoever without starting fluid ten you've got me.

-Russell
1990 Toyota Cressida 7MGE 3l I6/5-speed manual
1987 S10 2.5 not even power brakes it's so base model
"You don't get to judge me for how I fix what you broke."
read this and obey or face my wrath
kamesama980 is offline  
post #3 of 40 Old 12-28-2007, 06:13 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

Yea It Only Starts Up With Starting Fluid And I Leave It Of For A While Ill Have 2 Do It Again , I Know Its Fuken Wierd I Cant Figure Out What It Is
blazin_low_713 is offline  
post #4 of 40 Old 12-30-2007, 03:01 PM
Registered User
 
Join Date: Dec 2005
Location: Liberal,Ks
Age: 66
Posts: 345

User is: bonestock is offline
Re: truck wont start unless i spray some starting fluid?

Friend of mine had this problem with a 2.8. Replace the coolant temp sensor and was good .

Bonestock
bonestock is offline  
post #5 of 40 Old 12-30-2007, 08:27 PM
Death before Dishonor
 
dropped_92sdime's Avatar
 
Join Date: Dec 2007
Location: in Mi house
Age: 26
Posts: 125

User is: dropped_92sdime is offline
Send a message via AIM to dropped_92sdime
Re: truck wont start unless i spray some starting fluid?

never had that problem with my 2.5 I just hit the key and if it didn't start the first time then I'd shut it off and hit it again and it fired right up, that happened to my ford ranger tho and i replaced the fuel filter and flushed the fuel lines and also checked for any dry rot on them and then put it back together
dropped_92sdime is offline  
post #6 of 40 Old 12-30-2007, 10:03 PM
Registered User
 
Join Date: Oct 2007
Age: 33
Posts: 14

User is: brian00 is offline
Re: truck wont start unless i spray some starting fluid?

id say fuel pump probaly shot replace it its not that pricey or go to harbor frieght and get a tester
brian00 is offline  
post #7 of 40 Old 12-31-2007, 08:39 AM
It's "Neanderthal"
 
SH-60B's Avatar
 
Join Date: Nov 2007
Location: Meriden/CT/USA
Posts: 5,411

User is: SH-60B is offline
Re: truck wont start unless i spray some starting fluid?

Can you have someone crank it while you look at the injector? It sounds like no fuel while cranking.

1996 2.2, 5 speed, std cab, Sonoma
Teamsters Local 1150
SH-60B is offline  
post #8 of 40 Old 12-31-2007, 10:38 AM
The Schnauzberrys
 
bmack8613's Avatar
 
Join Date: Jan 2005
Location: Auburndale - FL
Age: 33
Posts: 2,399

User is: bmack8613 is offline
Re: truck wont start unless i spray some starting fluid?

I had the same problem with mine after i did a tune up, it would only run if gas was dumped or starter fluid. It turned out that i broke a small tab off of the distributor when i was replacing the cap.... that sucked, got a new distributor and was extra careful and it runs great now

Quote:
Originally Posted by nox View Post
i usually pop a boner so big that it honks the horn
I like to drag my balls on the ground!
bmack8613 is offline  
post #9 of 40 Old 12-31-2007, 05:48 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

Well I Guess Ill Replace The Fuel Pump Beacuse I Have A Brand New Fuel Injector And Fuel Filter On It
blazin_low_713 is offline  
post #10 of 40 Old 01-07-2008, 09:21 PM
Forum Dictator
 
What?'s Avatar
 
Join Date: Jan 2004
Location: Hell
Posts: 20,395

User is: What? is offline
Re: truck wont start unless i spray some starting fluid?

http://www.s10forum.com/forum/f105/i...lation-303943/

R.I.P. Grant ('82-'02), BagNDragS10 ('80-'06), Loenuff ('66-'07), Terryl ('57-'09) Gearstix ('93-'10), Gimp ('84-'16)

If you have any problem, issue, thread/post change, request. Feel free to PM me.
What? is offline  
post #11 of 40 Old 01-07-2008, 11:34 PM
square body man
 
irondukeman's Avatar
 
Join Date: Dec 2007
Location: Savannah
Posts: 218

User is: irondukeman is offline
Re: truck wont start unless i spray some starting fluid?

Quote:
Originally Posted by blazin_low_713 View Post
well my trck will not start up unless i spray some starting fluid in the tbi, but one its on on it runs great with no problem. i just changed my fuel filter, injector and did a tune up on it what can it be.
fuel pump man, these things quit alot... has the truck sat for a while?
irondukeman is offline  
post #12 of 40 Old 01-10-2008, 04:16 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

yea im goin 2 change it and see what happens from there
blazin_low_713 is offline  
post #13 of 40 Old 01-23-2008, 07:19 PM
Too Broke
 
Kingtut777's Avatar
 
Join Date: Dec 2002
Location: Lowsy Louisa, KY
Age: 36
Posts: 175

User is: Kingtut777 is offline
Send a message via MSN to Kingtut777 Send a message via Yahoo to Kingtut777
Re: truck wont start unless i spray some starting fluid?

Be easy with the starting fluid, as the motor becomes addicted to the ether (starting fluid).

Whoever appeals to the law against his fellow man is either a fool or a coward.
Whoever cannot take care of himself without that law is both.
For a wounded man shall say to his assailant,'If I live, I will kill you. If I die, you are forgiven'.
Such is the rule of honor.
Kingtut777 is offline  
post #14 of 40 Old 01-24-2008, 03:03 PM
It's "Neanderthal"
 
SH-60B's Avatar
 
Join Date: Nov 2007
Location: Meriden/CT/USA
Posts: 5,411

User is: SH-60B is offline
Re: truck wont start unless i spray some starting fluid?

Quote:
Originally Posted by Kingtut777 View Post
Be easy with the starting fluid, as the motor becomes addicted to the ether (starting fluid).


LOL!Yeah, mine's already addicted to gasoline, I don't want it picking up any other bad habits!

1996 2.2, 5 speed, std cab, Sonoma
Teamsters Local 1150
SH-60B is offline  
post #15 of 40 Old 01-24-2008, 08:32 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

What Will Happen If I Keep Doing It, Thats The Only Way For Me 2 Start It
blazin_low_713 is offline  
post #16 of 40 Old 01-24-2008, 10:33 PM
The Eye is watching you!!
 
kamesama980's Avatar
 
Join Date: Nov 2007
Location: dekalb, IL, USA
Age: 31
Posts: 963

User is: kamesama980 is offline
Send a message via AIM to kamesama980 Send a message via Yahoo to kamesama980
Re: truck wont start unless i spray some starting fluid?

it's too late. it's already addicted.

-Russell
1990 Toyota Cressida 7MGE 3l I6/5-speed manual
1987 S10 2.5 not even power brakes it's so base model
"You don't get to judge me for how I fix what you broke."
read this and obey or face my wrath
kamesama980 is offline  
post #17 of 40 Old 01-25-2008, 01:43 AM
square body man
 
irondukeman's Avatar
 
Join Date: Dec 2007
Location: Savannah
Posts: 218

User is: irondukeman is offline
Re: truck wont start unless i spray some starting fluid?

be careful using ether/starting fluid... it burns way hotter than gasoline, therefore burning your rings up, and valves if you rev it high rpms, acts kinda like a torch on the valves, its also dangerous because it will backfire into the intake, burning any gas there

93 Blazer (bone stock)
2010 z06 corvette (sold)
searching for my next big toy
irondukeman is offline  
post #18 of 40 Old 01-25-2008, 02:36 AM
Advanced Life Form
 
Megaglow_Z's Avatar
 
Join Date: Jan 2007
Location: Benton La.
Age: 44
Posts: 791

User is: Megaglow_Z is offline
Re: truck wont start unless i spray some starting fluid?

Quote:
Originally Posted by blazin_low_713 View Post
What Will Happen If I Keep Doing It, Thats The Only Way For Me 2 Start It
Well,see if you can get a small spray bottle with gas in it.then give it a squirt using that??
Would be better then using starting fluid all the time.
But you really need to get it fixed.

Megaglow_Z is offline  
post #19 of 40 Old 01-25-2008, 02:20 PM
Forum Dictator
 
What?'s Avatar
 
Join Date: Jan 2004
Location: Hell
Posts: 20,395

User is: What? is offline
Re: truck wont start unless i spray some starting fluid?

you cannot get any cheaper than this unless ebay route for cheaper fuel pump bug you get what you pay for

this is pretty good deal because you buying the pump alone while buying the 1 from auto store/dealership, you buying the whole set, mount., fuel sending unit, float, pump, etc

R.I.P. Grant ('82-'02), BagNDragS10 ('80-'06), Loenuff ('66-'07), Terryl ('57-'09) Gearstix ('93-'10), Gimp ('84-'16)

If you have any problem, issue, thread/post change, request. Feel free to PM me.
What? is offline  
post #20 of 40 Old 01-25-2008, 03:28 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

i know i need it fixed but cant figure out what it is
blazin_low_713 is offline  
post #21 of 40 Old 01-27-2008, 07:06 PM
Registered User
 
Join Date: Dec 2005
Location: Liberal,Ks
Age: 66
Posts: 345

User is: bonestock is offline
Re: truck wont start unless i spray some starting fluid?

I don't know why people always say "fuel pump" without reading the post. You state that it runs fine after you get it started--that means the fuel pump is doing its job. I also think you said it will start fine until it sets for a while (cools down). Then you have to spray it again.---COOLANT TEMP SENSOR.

Bonestock
bonestock is offline  
post #22 of 40 Old 01-27-2008, 07:34 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

Where Is That Located If U Have A Pic Or Something I Would Appreciate It
blazin_low_713 is offline  
post #23 of 40 Old 01-27-2008, 08:03 PM
Rarely goes over 20mph
 
beaniebmx's Avatar
 
Join Date: Jun 2007
Location: Iowa
Posts: 3,164

User is: beaniebmx is offline
Re: truck wont start unless i spray some starting fluid?

coolant temp sensor is located on the thermostat/water intake housing. it faces the a/c compressor and is threaded into the water inlet has a connector on i



03 S10 Ext Cab-BD 3.5" bagged- 18/20s its ORANGE
1991 s10 reg cab 5spd- SOLD- biggest mistake
1985 2wd 2dr jimmy-totaled- samwhiched in a 5 car pileup

Last edited by beaniebmx; 01-27-2008 at 08:05 PM.
beaniebmx is offline  
post #24 of 40 Old 01-27-2008, 09:31 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

ok i see wich one it is
blazin_low_713 is offline  
post #25 of 40 Old 01-28-2008, 06:39 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

well i changed the coolant temp sensor today and no luck still wont start
blazin_low_713 is offline  
post #26 of 40 Old 02-05-2008, 08:49 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

i finally put a new fuel pump and still no luck im out of ideas
blazin_low_713 is offline  
post #27 of 40 Old 02-06-2008, 01:57 PM
Too Broke
 
Kingtut777's Avatar
 
Join Date: Dec 2002
Location: Lowsy Louisa, KY
Age: 36
Posts: 175

User is: Kingtut777 is offline
Send a message via MSN to Kingtut777 Send a message via Yahoo to Kingtut777
Re: truck wont start unless i spray some starting fluid?

Have you checked the timing? You may want to try retarding the timing (turn the distrubutor counter clockwise, just a little). If this helps check the vacuum line going to your disributor. It may need replaced, or the timing advance in distibutor may need replaced. Just something to check out, hope it helps.

Whoever appeals to the law against his fellow man is either a fool or a coward.
Whoever cannot take care of himself without that law is both.
For a wounded man shall say to his assailant,'If I live, I will kill you. If I die, you are forgiven'.
Such is the rule of honor.
Kingtut777 is offline  
post #28 of 40 Old 02-06-2008, 02:01 PM
Too Broke
 
Kingtut777's Avatar
 
Join Date: Dec 2002
Location: Lowsy Louisa, KY
Age: 36
Posts: 175

User is: Kingtut777 is offline
Send a message via MSN to Kingtut777 Send a message via Yahoo to Kingtut777
Re: truck wont start unless i spray some starting fluid?

If there isn't a vacuum line running to your distributor it will use a spring advance (it's been a while so I don't remember). You'll need to check the spring, it may be weak or broken.

Whoever appeals to the law against his fellow man is either a fool or a coward.
Whoever cannot take care of himself without that law is both.
For a wounded man shall say to his assailant,'If I live, I will kill you. If I die, you are forgiven'.
Such is the rule of honor.
Kingtut777 is offline  
post #29 of 40 Old 02-06-2008, 02:33 PM
Registered User
 
vettezx-6's Avatar
 
Join Date: Dec 2007
Location: Bluffton, IN
Age: 35
Posts: 18

User is: vettezx-6 is offline
Re: truck wont start unless i spray some starting fluid?

Let's reason this out. To get the truck to start you have to add fuel, correct? Therefore you have a fuel delivery problem, not an ignition problem. GM fuel pumps are notorious for being too weak to start the engine. Once the engine is running the pump has no problem supplying enough fuel for the truck to operate normally. Since you replaced the pump you should have that ruled out.

Next move should be to make sure the fuel pump "prime" is working. Basically the ECM will run the fuel pump for about 2 seconds when you turn the key to the run position. You can check this by having someone turn the key while you listen for the pump to run (don't crank the engine over, just turn the key to run). You will have to turn the key to off for about 5 seconds to reset the ECM prime. If your pump is not priming you will have to crank it for a really long time to get the engine to fire - assuming it ever would.
vettezx-6 is offline  
post #30 of 40 Old 02-06-2008, 05:52 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

Thanxx Guys Ill Take All That In Mind
blazin_low_713 is offline  
post #31 of 40 Old 03-02-2008, 11:03 AM
Registered User
 
leadfoot's Avatar
 
Join Date: Feb 2003
Location: Upstate NJ
Posts: 138

User is: leadfoot is offline
Question Re: truck wont start unless i spray some starting fluid?

Did you figure out your problem?

I'm having the same prob with my '02 Xtreme 4.3. Truck sat for awhile and won't start, but I remember it was not running good the last time I used it. (would not downshift when I floored it-auto trans)

I smell gas and it almost wanted to fire, but does not -even with starting fluid!

Truck only has 40K on it and seems to be falling apart sitting in the driveway??

Doug E
-----------------
'02 Xtreme: Syclone powered; AWD; 4.3/4L60e; 0411PCM; Coil overs, 4" static drop, 4WDisc brakes; A/C delete, cruise delete, remote oil delete.

'06 Mazda 6i sport
'66 Chevelle convertible (6.5) SS clone
leadfoot is offline  
post #32 of 40 Old 03-02-2008, 11:13 AM
I gots a new toy
 
lodime's Avatar
 
Join Date: Jan 2005
Location: Hubert, NC
Age: 29
Posts: 587

User is: lodime is offline
Re: truck wont start unless i spray some starting fluid?

I have the, to the T, same freaking problem and it sux, any luck with yours?

Ryan
lodime is offline  
post #33 of 40 Old 03-02-2008, 04:20 PM
Registered User
 
leadfoot's Avatar
 
Join Date: Feb 2003
Location: Upstate NJ
Posts: 138

User is: leadfoot is offline
Re: truck wont start unless i spray some starting fluid?

i heard the pump prime when I keyed the ignition. Ordered the fuel pressure tester, so I will diagnose the fuel system when that gets here.

On most of my last fuel injected cars it was usually as the cam position sensor that prevented start up, but I am not sure if this truck has one??

I also may drain the tank and replace the fuel as I think I may have old/stale fuel -like I have nothing better to do...

Doug E
-----------------
'02 Xtreme: Syclone powered; AWD; 4.3/4L60e; 0411PCM; Coil overs, 4" static drop, 4WDisc brakes; A/C delete, cruise delete, remote oil delete.

'06 Mazda 6i sport
'66 Chevelle convertible (6.5) SS clone
leadfoot is offline  
post #34 of 40 Old 03-03-2008, 09:29 PM Thread Starter
Registered User
 
blazin_low_713's Avatar
 
Join Date: Mar 2007
Location: SCREWSTON TX
Age: 31
Posts: 221

User is: blazin_low_713 is offline
Re: truck wont start unless i spray some starting fluid?

nope i have not been able 2 figure it out , but know i have more problems with it
blazin_low_713 is offline  
post #35 of 40 Old 12-03-2011, 10:42 AM
Red Dog's Blazer
 
Chris's_96Blazer's Avatar
 
Join Date: Jul 2005
Location: Haralson county ,Georgia
Age: 36
Posts: 318

User is: Chris's_96Blazer is offline
Send a message via Yahoo to Chris's_96Blazer
Re: truck wont start unless i spray some starting fluid?

I have had the same issue with mine for past 6 months, the shops around here want to much to tell me what wrong ( they said they can do tests on it and tellme ) i really so bad need it fixed, its very very annoying to have to pop hood spray it then crank it.

sometimes mine will crank if i keep turning the key for 5 secs, then turn off, turn on again ( priming it as someone said) but it doesn't always do it by itself.

its getting colder and colder and don't want to be standing out in the cold, wet,snow doing this. hope I can get it fixed soon


BTW I have put on a new fuel filter, throttle position sensor and cleaned the mass air sensor none of these helped anything

sorry i just now seen the date this thread is WAY old

"If its too loud,your too old"
1985 S10 Blazer 2.8 Auto 4x4
Sony Cd/Mp3/wma Player 2 12" subs

Chris.
Chris's_96Blazer is offline  
post #36 of 40 Old 12-03-2011, 11:25 PM
Wire Splicin Fool :-)
 
lesterl's Avatar
 
Join Date: May 2008
Location: Harrisonville, MO
Age: 36
Posts: 8,692

User is: lesterl is offline
Re: truck wont start unless i spray some starting fluid?

Test your fuel pressure, now if you have a 96, then you are in the WRONG forum and you should be looking for a higher fuel pressure (around 60 PSI on prime, any lower than that and you should suspect the fuel pump.)

That being said for those of this forum, fuel pressure is around 12 PSI on prime, much below 9PSI and they wont start/ start well.....

Sensor Resistance Chart -> http://www.s10forum.com/forum/attachments/f107/98606d1222052466-little-help-needed-gm-sensor-chart.gif
1997 Venture 3.4l Auto / 2006 Malibu Maxx 3.5l Auto / 1995 Tahoe 5.7l TBI Auto / 1998 GMC Sierra Z71
Will have another S10 one day.... Anyone have a freebie? :-)
lesterl is offline  
post #37 of 40 Old 12-03-2011, 11:32 PM
Registered User
 
Join Date: Nov 2011
Location: visalia
Age: 24
Posts: 13

User is: 805pyro is offline
Re: truck wont start unless i spray some starting fluid?

wat u shuld try dng is run a switch to ur ignition fuse. cuz when i turn the switch on ur turns on the fuel pump nd u wuld hear the fuel pump prime while its priming turn on the truck nd it shuld fire right up. its like a kill switch to. wont turn on unless the switch is on. i did it to my truck. the fuse im tlkng about it the one that turns on ur odometer nd fuel pump. cuz theres like 5 ignition fuse's.
805pyro is offline  
post #38 of 40 Old 07-23-2015, 12:13 PM
Registered User
 
Join Date: Jul 2015
Age: 62
Posts: 2

User is: harper789 is offline
Re: truck wont start unless i spray some starting fluid?

So blazen_low_713 did you ever figure out the problem? I have same issue - need to prime my 2002 S10 to get it to start. Runs great otherwise.
harper789 is offline  
post #39 of 40 Old 07-23-2015, 01:22 PM
Boozebag
 
Mad Max's Avatar
 
Join Date: Jun 2009
Location: Baton Rouge, LA
Posts: 6,598

User is: Mad Max is offline
Re: truck wont start unless i spray some starting fluid?

Welcome...
Did you happen to see how old this thread is?
The OP probably doesn't have this truck anymore.

Suggestion:
Start your own thread and describe your problem.

S10 addiction: (1)'82 S10, 383, 700R4, Shorty,
(2) '85 S10, 3.4, 700R4 4x4 stretch cab (Redneck Truck), (3) '90 S10 2.5, 5 speed shorty,
(4) '91 S10, Built 3.4, 5 speed shorty (Voodoo Truck), (5) '92 S10, 2.5, 5 speed shorty, (Barbie Truck),
(6) '83 S10, 327, TH 350, shorty (13.00 best),
(7) '92 S10, 2.5 5 speed, Shorty,
(8) 1979 LUV, Buick 3.8 V6, TH 350 Shorty.
Mad Max is offline  
post #40 of 40 Old 06-08-2016, 01:42 AM
Registered User
 
Join Date: Jun 2016
Posts: 1

User is: gt4daddy is offline
Re: truck wont start unless i spray some starting fluid?

throttle position sensor
gt4daddy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome